Jump to content
Sign in to follow this  
limpid

Embedding YouTube

Recommended Posts

How to embed YouTube videos

  1. In YouTube, click "Share"
  2. A link is displayed, copy this using ctrl-c (or however you usually copy e.g. right click + copy / cmd+c ). Note: If you want to start at a particular point in the video, click the start at box and enter the time, then copy the link  - see image.
  3. 566fe9aa3401f_ScreenShot2015-12-15at10.0
  4. To find out if embedding of the link you have just copied is permitted, click "embed" (do not copy the new youtube link it presents)
  5. If it says embedding is not allowed, then embedding on VT will not work and you can only post a link.
  6. Back in VT, use your browser's "paste as plain text" option. (ctrl-shift-v on most things, Command-Shift-Option-V on MacOS). If your browser doesn't have its own, use ctrl-rightclick
  7. Press return
  8. Click submit
  9. When it doesn't work, realise that you didn't do step 6
  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, supernova26 said:

Or copy and paste the URL as if you're posting a picture. That works too :) 

I'm pretty sure it will only do this if your browser is set up to "paste as plain text" by default, but I might be wrong.

Share this post


Link to post
Share on other sites

Thanks for fixing up that youtube embed I just posted, Limpid.

Would love to know what I did wrong as I tried to follow the instructions above. 

Share this post


Link to post
Share on other sites

You had the wrong URL for a start. I don't actually know where you got that URL from, it's certainly not the one you get following the steps above.

Share this post


Link to post
Share on other sites

Depends on at which point you edited my post ;)

i copied the url from the address bar, didn't work. Then I tried the link in the share option, didn't work. Finally tried the embed option as outlined above and it came out all messed up again. I was going through the process again when I saw you'd bailed me out. What's odd though is that in one of the earlier attempts, the video did seem to be embedded in the editor but when I hit submit, it posted it as just the link. And I used to be really good at posting and embedding on the old site too. I might have another stab at it in the testing forum tomorrow.

Share this post


Link to post
Share on other sites

@choffer Please don't take the above as an "outline". It's very specific.

From your description, you used the incorrect URL, then the correct URL without pressing RETURN. And then tried another wrong URL.

Just follow the steps exactly one by one. It's easy. And it'll be automatic after a few goes.

Share this post


Link to post
Share on other sites

Bingo! Of course it was the pressing return bit. I will return to the corner to stand and contemplate my poor observation skills :)

 

  • Like 1

Share this post


Link to post
Share on other sites

For me it's as easy as copying the video's URL, pasting it into the text box here at VT and pressing return. Bingo.

I use Chrome, I have no idea what the settings are but I haven't changed them to my knowledge so I assume this can be done off the default setting.

Share this post


Link to post
Share on other sites

I think pressing RETURN makes all the difference. That's when the editor does it's processing.

  • Like 1

Share this post


Link to post
Share on other sites

It's alright, I got it eventually...you don't want the URL from after pressing embed, the URL before.

I was thinking letting iframes in would be a bad idea.

Share this post


Link to post
Share on other sites

Feel free to edit them. Or suggest other wording.

If you follow exactly what it says, not interpreting things, not skipping steps, then it will work.

  • Like 1

Share this post


Link to post
Share on other sites

<iframe width="560" height="315" src="https://www.youtube.com/embed/6mor6ZDtd9I" frameborder="0" allowfullscreen></iframe>

 

Edited by Kingman

Share this post


Link to post
Share on other sites

Sign in to follow this  

×
×
  • Create New...
Â